Una gran falla de seguridad de Linux tiene 3 años afectando a Android

0
361

La seguridad es un punto esencial en lo que debe enfocarse cualquier desarrollo de software, y cuando se trata de un sistema operativo altamente utilizado como Linux, una falla podría significar poner en peligro a equipos de millones usuarios, esto puede ser el caso actual de la plataforma,  ya que un reciente reporte de la importante compañía  de seguridad, Perception Point, ha revelado una gran falla en el sistema, que permitiría a un usuario remoto conectarse  a cualquier equipo de manera no autorizada, y con ello ejecutar código malicioso con beneficios de usuario Root, pero otro de los puntos más importantes revelados en esta investigación es el hecho de que de igual manera afecta a usuarios con equipos Android.

Falla en Linux reflejada en Android

Altera los archivos del Kernel, convirtiéndolos en la fuente del ataque

Más impresionante aun es el hecho de que la falla no es nueva, ya que la compañía que ha llevado a cabo el descubrimiento se ha percatado que sus orígenes se remontan con la versión del Kernel 3.8, el cual, como bien es sabido, fue lanzado al público a principios del año 2013, es decir, los usuarios tienen 3 años estando a merced de posibles ataques.

Kernel Vulnerable Seguridad

La falla  específicamente es encontrada en los archivos almacenados  por el kernel referentes a certificados de seguridad y otros tipos de datos que son de suma importancia, pero que, solamente son utilizados por el núcleo, obviamente por motivos de resguardar dichos datos de forma segura, sin embargo la seguridad de la versión 3.8 y posterior no es del todo fuerte.

Perception Point Investigacion Nucleo

Para probar el hecho Perception Point hizo pruebas donde pudo demostrar claramente lo que representa esta amenaza, ya que pudo sustituir dichos archivos por código que formaría a ser ejecutado de forma silenciosa en el núcleo del sistema.

La compañía ha enviado los reportes a la comunidad encargada de mantener los kernels de Linux, con ello se espera que próximamente sea enviado un parche de seguridad a todos los usuarios de Linux, sin embargo para los usuarios Android podría significar otra historia, ya que como bien es sabido las actualizaciones tienen que ser aprobadas por las compañías fabricantes de teléfonos, sin mencionar que en muchos casos también interviene la operadora móvil a la que correspondan.

Android Linux Ataque Falla

Sin embargo una esperanza queda para los usuarios de Android 5.0 Lollipop, debido a las siguientes declaraciones de Google:

Android SELinux, la política de seguridad incluida en las versiones 5.0 y posterior, evitará que aplicaciones de terceros sean ejecutadas, y así protegiéndolas del código infectado

Todo parece indicar que de todas maneras los usuarios con versiones anteriores a la mencionada quedaran totalmente vulnerables a los ataques, queda esperar por parte de los usuarios si las compañías toman cartas en el asunto.

No hay comentarios

Dejar una respuesta