Saltar al contenido

Cómo dividir una columna usando la función SI/IF () en Excel

Abr 24, 2020
Cómo dividir una columna usando la función SI/IF () en Excel

Todos heredamos hojas de Microsoft Excel que no se adaptan a nuestra rutina de trabajo. Si se trata de una simple hoja de seguimiento de algún tipo, por lo general puede cambiar las cosas para adaptarse a sus necesidades de trabajo.

Por ejemplo, no es raro trabajar en una hoja que sigue el diseño tradicional de una base de datos en lugar de una estructura de hoja financiera. Cuando esto ocurre, normalmente se puede renovar la estructura empleando unas pocas expresiones en lugar de crear la nueva estructura desde cero. En este artículo, utilizaré dos funciones SI ó IF() para dividir una simple hoja de “base de datos” en varias columnas, basándose en un valor en otra columna.

Estoy usando Office 365, pero se puede trabajar con versiones anteriores. Para su conveniencia, puede descargar el archivo .xlsx de demostración, pero también puede trabajar con sus propios datos. Las expresiones funcionarán en la edición del navegador.

Por qué podría usar la función SI ()

En la base de datos, muchos datos se definen por tipo. De esa manera, sólo se necesita un campo para el valor real. También puede hacerlo con Excel, como se muestra en la figura A.

Esta tabla simplificada utiliza sólo un campo de valor y define cada valor como un débito o un crédito. En Excel, también puede verlo como dos columnas de valores, una para los débitos y otra para los créditos, y ningún campo de tipo de transacción porque se identifica por cada cabecera de columna.

Figura A
para que usar la funcion si if

Si heredas una hoja que se parece a la de la figura A, pero quieres una hoja más tradicional en la que los dos tipos de transacción estén en columnas diferentes, no te quedarás atascado. Puede probar primero con Texto a columnas, pero en este caso esa característica no funcionará porque funciona con una sola columna. No puede usarla para dividir valores basados en un valor condicional en una segunda columna. En su lugar, usaremos dos funciones IF(), una para el débito y otra para el crédito.

La función SI () utiliza la siguiente forma: SI(condición,verdadero,falso)

Donde condición es un valor o expresión que equivale a verdadero o falso y los argumentos de verdadero y falso identifican lo que sucede cuando la condición es verdadera o falsa, respectivamente. Ahora, pongamos esta función en uso.

Cómo hacer la expresión de débito

Hay varias funciones de cadena para delimitar las cadenas, pero necesitamos una expresión condicional. Por esa razón, usaremos dos expresiones SI () diferentes: Una que devuelve el valor de débito y otra que devuelve los valores de crédito.

Comencemos con los valores de débito. Primero, cree una nueva columna introduciendo Débito en la celda E2. Si trabajas con un objeto de la Tabla (como yo), Excel extenderá automáticamente la Tabla. En E3, introduce la siguiente expresión:

=SI(C3=”Débito”,D3,””)

Copia la expresión al resto de la columna. La figura B muestra los dos valores de débito de la columna E.

Figura B

como utilizar la funcion si if
En este momento, la columna E contiene sólo los valores de débito existentes en la columna D. Si el valor de la columna C es igual a “Débito“, la función devuelve el verdadero argumento, que es el valor correspondiente de la columna D. En caso contrario, la función devuelve una cadena en blanco (“”). Como puede verse, la columna E contiene sólo dos valores, los valores en los que el texto correspondiente de la columna C es Débito. Ahora, necesitamos una columna para los créditos.

Cómo hacer la expresión de crédito

Ahora que has dividido los valores de débito con una expresión SI(), probablemente puedas hacer los valores de crédito por tu cuenta. En F2, introduzca Crédito, y de nuevo el objeto Tabla extenderá la Tabla. Usaremos la misma función básica, pero esta vez, usaremos Crédito como condición:

=SI(C3=”Crédito”,D3,””)

Como pueden ver en la figura C, ahora tenemos dos columnas: La columna E muestra los valores de débito, y la columna F muestra los valores de crédito. Pero aún no hemos terminado.

Figura C

mostrando valor funcion if si

La diferencia entre las formulas y los valores

Ahora mismo, parece que hemos terminado, pero en realidad no. Los valores de las columnas E y F son el resultado de dos funciones SI(), y necesitamos valores literales. Las funciones SI() son sólo un medio temporal de introducir los valores existentes en la estructura que queremos usar en el futuro.

Para convertir las fórmulas, haga lo siguiente:

1.-Seleccione E3:F6 (el rango que contiene las funciones SI()).
2.-En el grupo Portapapeles (en la pestaña Inicio), haga clic en Copiar.
3.-En el mismo grupo, haga clic en el menú desplegable Pegar y elija Valores (la primera opción) en la sección Pegar valores (Figura D). Después de hacerlo, los valores de las columnas E y F son ahora valores literales: las funciones SI() han desaparecido.
Figura D
convertir las fórmulas if si

Cómo limpiar las columnas

Ahora que tienes los valores originales divididos en columnas, puedes limpiar las cosas un poco. Primero, querrás dar formato a los nuevos valores en las columnas E y F. En este caso, aplica el formato Moneda. En segundo lugar, debes eliminar u ocultar las columnas C y D, que ya no son necesarias. La figura E muestra los resultados finales. Ahora, los usuarios pueden ingresar débitos y créditos en las columnas E y F, respectivamente.

Figura E

Cómo limpiar tus columnas

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.

ACEPTAR
Aviso de cookies